Critical issue with fallback keys


#1

I have purchased some EOS during crowdsale. Keypair was generated on official site (eos.io) in accordance with instructions. I correctly registered my EOS public key and claimed tokens, in accordance with instructions. All done accurately, my private key is exactly correct (printed on paper, carefully checked with initial copy-paste and with paper). When crowdsale was ended, I tried to use my EOS account (first attempt - december 15). But wallets (Scatter, Greymass EOS voter) says that my private key is invalid! I can only to watch my EOS account with my public key, and all balances are ok. I googled this problem, and found that many people have same bug. There is a solution by EOS community: fallback key.

So, I used fallback EOS keypair. It works, but I still cannot to send transaction (small part of my liquid EOS), Scatter throws this error:

error {"code":500,"message":"Internal Service Error","error":{"code":3090003,"name":"unsatisfied_authorization","what":"Provided keys, permissions, and delays do not satisfy declared authorizations","details":[{"message":"transaction declares authority '{\"actor\":\"g4ydmnbtg4ge\",\"permission\":\"active\"}', but does not have signatures for it under a provided delay of 0 ms, provided permissions [], provided keys [\"(my EOS public key)\"], and a delay max limit of 3888000000 ms","file":"authorization_manager.cpp","line_number":517,"method":"check_authorization"}]}}

I checked Scatter node address, it is normally reachable for me. I googled this error and find some people who has same error. But no solution found.

One obvious fact is that fallback keypair hasn’t any EOS account (any block explorer says that no EOS account found with my fallback public key). Other people who used fallback have the same problem: keypair without account. And what we need to do?

It seems that simply I need to create EOS account which owner and active permissions are my public fallback key. I did it successfully, but actually obtained new account that hasn’t any of my balance. Also, in Scatter I tried to connect my account that I received after crowdsale (which has “invalid” private key). It connected successfully, all balances are ok, but I still cannot to do any transaction (same error).

So, how to make EOS account with all my EOS from crowdsale, which controlled by my fallback key?

I use latest version of Scatter.

I writed to B1 support, to 15 top block producers, to Greymass and Scatter support, to Larimer’s twitter… and no any answer or helpful answer to now.


#2

No solution to now. No helpful answer from anywhere (BPs, Block.one, Larimer etc). :frowning_face: